Yealink SIP-T58W Pro VoIP telefoon

In stock
SKU
12800204

With its innovative Bluetooth handset, the Yealink T58W Pro is revolutionising wireless communication by allowing users to move around freely and easily.

  • Product type: IP telephone
  • Dual-Tone Multi-Frequency (DTMF) modes: in-band, out-of-band, SIP-info
  • Phone book capacity: 1,000 entries
  • Number of keys on the keyboard: 27
  • Display: LCD

No faffing about with cables, no annoying noises

With its innovative Bluetooth handset, the Yealink T58W Pro is revolutionising wireless communication by allowing users to move around freely and easily.

Thanks to Yealink’s professional-grade hardware and advanced acoustic algorithm, the T58W series excels at filtering out noise, ensuring that every call remains clear and crisp.

Take your business phone to the next level

Thanks to the improved chipsets, the T58W series offers better system performance, with fast response times and greater processing power. The use of the Android 9.0 operating system has also improved data encryption, access management, response times and integration capabilities, ensuring it meets the demands of modern business and future sustainability.

Security, configuration and management at company level

As data security is one of the key priorities, the new phones use Arm TrustZone technology to protect all kinds of ARM-based data and apps.

Thanks to support from the Yealink/Unify Square Device Management Platform, the management, configuration and updates of the T58W series can be carried out in a streamlined and straightforward manner.

Specifications

Design

Product typeIP telephone
Mobile phone modelWired telephone
Product colourGrey
For wall mountingYes

Achievements

Dual-Tone Multi-Frequency (DTMF) modesIn-band, Out-of-band, SIP-info
Compatibility with hearing aidsYes

Phone features

Answering machineYes
Call againYes
Caller IDYes
Phone book capacity1,000 entries
Call on holdYes
Speed dialYes
IntercomYes
Putting a call on holdYes
Call forwardingYes
Telephone meetingYes
'Do Not Disturb' functionYes
Call parkYes
Take over the callYes
Anonymous phone callYes
Block anonymous callsYes
Full-duplexYes
Number of VoIP accounts12
Call backYes
Transferring a callYes
Message Waiting Indicator (MWI)Yes

Management functions

Integrated voicemailYes
Number of keys on the keyboard27
Number of function keys7

Display

DisplayLCD
Screen diagonal17.8 cm (7")
Screen resolution1024 × 600 pixels
TouchscreenYes
Touchscreen typeCapacitive

Camera

Front-facing cameraYes
Rear cameraYes

Audio

LoudspeakerYes
Mute the microphoneYes
Audio codecsG.711a, G.722, G.723.1, G.726, G.729, G.729A, G.729B, iLBC
Noise cancellationYes
Voice activity detectionYes
Adaptive jitter buffersYes
Automatic gain controlYes
Generating comfort noise (CNG)Yes
Concealment of packet loss (PLC)Yes

Video

Video callNo

Network

Ethernet LANYes
Type of Ethernet LAN interfaceGigabit Ethernet
Ethernet LAN data rates1000 Mbit/s
Wi-FiYes
Wi-Fi standards802.11a, 802.11b, 802.11g, Wi-Fi 4 (802.11n)
BluetoothYes
Bluetooth version4.2
Supported network protocolsIPv4/IPv6, SIP v1 (RFC 2543), v2 (RFC 3261), UDP/TCP/DNS-SRV (RFC 3263)
Support for Quality of Service (QoS)Yes
Security algorithms256-bit AES, HTTPS, TLS, WPA2, WPA3
Network standardsIEEE 802.11a, IEEE 802.11b, IEEE 802.11g, IEEE 802.11n, IEEE 802.1x, IEEE 802.3af

Gates and interfaces

Number of USB 2.0 ports2
Ethernet LAN (RJ-45) ports2
Number of RJ-9 ports2

Assets

Power over Ethernet (PoE)Yes

Working conditions

Operating temperature (T-T)0 - 40 °C
Relative humidity during use (H-H)10 - 95%

Weight and dimensions

Width259.4 mm
Depth220 mm
Height215 mm
Weight8.86 kg
Width of the packaging324 mm
Depth of the packaging293 mm
Height of the packaging128 mm
Weight of the packaging9.56 kg

Contents of the pack

Number of handles supplied1 item(s)
Write Your Own Review
You're reviewing:Yealink SIP-T58W Pro VoIP telefoon
© 2026 BNS Data Logistics. All rights reserved.