The store will not work correctly when cookies are disabled.
JavaScript seems to be disabled in your browser.
For the best experience on our site, be sure to turn on Javascript in your browser.
Yealink SIP-T42U IP Phone
Yealink’s Optima HD Voice technology combines advanced hardware and software with broadband technology to deliver optimum sound quality.
Product type: IP telephone Phone book capacity: 1,000 entries Number of programmable keys: 6 Display: LCD Ethernet LAN interface type: Gigabit Ethernet
Sound and hearing with remarkable clarity Yealink’s Optima HD Voice technology combines advanced hardware and software with broadband technology to deliver optimum sound quality.
Efficient implementation and management The Yealink T4U series supports effortless large-scale deployment and Zero Touch Provisioning via Yealink’s Redirection and Provisioning Service (RPS) and the boot mechanism, making device management much easier and more efficient for administrators.
Two USB ports for flexible expansion options Bluetooth/Wi-Fi/wireless headset dongles The optional USB dongles allow you to enable features such as Bluetooth and Wi-Fi on the T42U, or to connect to a compatible wireless headset.
Specifications Design Product type IP telephone Mobile phone model Cordless handset Product colour Grey Device lock Yes For wall mounting Yes Assembly Desk/wall
Phone features Call again Yes Caller ID Yes Phone book capacity 1,000 entries Call on hold Yes Eye-catching ring Yes Speed dial Yes Putting a call on hold Yes Call forwarding Yes Telephone meeting Yes 'Do Not Disturb' function Yes Call park Yes Take over the call Yes Anonymous phone call Yes Block anonymous calls Yes Full-duplex Yes Call now Yes Number of VoIP accounts 12 Transferring a call Yes Call history Yes
Management functions Integrated voicemail No Number of programmable keys 6 Number of function keys 5
Display Display LCD Screen diagonal 6.86 cm (2.7") Screen resolution 192 × 68 pixels
Camera Network Ethernet LAN Yes Type of Ethernet LAN interface Gigabit Ethernet Wi-Fi Yes Bluetooth Yes Supported network protocols IPv4/IPv6, SIP v1 (RFC 2543), v2 (RFC 3261), UDP/TCP/DNS-SRV (RFC 3263) Support for Quality of Service (QoS) Yes Security algorithms 256-bit AES, HTTPS, TLS, WPA2, WPA3 Network standards IEEE 802.11a, IEEE 802.11b, IEEE 802.11g, IEEE 802.11n, IEEE 802.1x, IEEE 802.3af
Gates and interfaces Number of USB 2.0 ports 2 Ethernet LAN (RJ-45) ports 2 Number of RJ-9 ports 2
Assets Power consumption (average) 2.2 W
Working conditions Operating temperature (T-T) -10 - 50 °C Relative humidity during use (H-H) 10 - 95%
Weight and dimensions Width 212 mm Depth 189 mm Height 175 mm Width of the packaging 627 mm Depth of the packaging 256 mm Height of the packaging 235 mm Weight of the packaging 63 kg
Contents of the pack Number of handles supplied 1 item(s) Includes mains adapter No
© 2026 BNS Data Logistics. All rights reserved.